Skip to content
12 febbraio , 2008 / Flax

Code::Blocks

Per gli amanti della programmazione ecco un’ambiente di sviluppo davvero completo e ben realizzato. Questo è il software che usiamo per programmare al Politecnico di Torino (che da ora in poi chiamerò poli 😀 ). L’installazione può essere effettuata semplicemente tramite i repo:

deb http://lgp203.free.fr/ubuntu/ gutsy universe
deb http://apt.wxwidgets.org/ gutsy-wx main

Autenticateli con:

wget -q http://lgp203.free.fr/public.key -O- | sudo apt-key add -
wget -q http://apt.wxwidgets.org/key.asc -O- | sudo apt-key add -

Ed infine installate il software con:

sudo apt-get install libcodeblocks0 codeblocks libwxsmithlib0 codeblocks-contrib

Beh, buona programmazione 🙂

Annunci

11 commenti

Lascia un commento
  1. liuk / Feb 12 2008 12:38 am

    ah sono usciti i repo per gutsy finlamente?fino a poco tmepo fa non ce n’era l’ombra…cmq, se vuoi, puoi anche fare una guida su quelle cose che ti ho detto oggi di gedit, ti linko il topic del forum di ubuntu che ti ho detto:

    http://forum.ubuntu-it.org/index.php/topic,154290.msg1021408.html#msg1021408

  2. Amurian / Feb 12 2008 12:55 pm

    Bella segnalazione, lo provo subito.
    Piccola nota: il primo comando wget è sbagliato, c’è scritto solo get.

  3. Flax / Feb 12 2008 2:17 pm

    Ops grazie mille Amurian, correggo al volo 🙂

  4. Lazza / Feb 13 2008 5:39 pm

    Che linguaggi supporta?

  5. liuk / Feb 13 2008 6:46 pm

    supporta sicuramente c, c++, java, html, css e credo altri ovviamente

  6. liuk / Feb 13 2008 6:48 pm

    ah no scusa, ti ho risposto pensando a gedit 😀 …mi pare di ricordare che code::blocks supporti solo c e c++

  7. DnaX / Mag 4 2008 3:56 pm

    Code::Blocks l’ho conosciuto grazie e te ed adesso sto facendo lì il mio progetto di algoritmi 😉

    ciao!

  8. kronakus / Set 7 2008 10:05 pm

    Ora sì che ho capito tutto… :S

  9. Flax / Set 8 2008 3:18 pm

    Beh commentando così viene veramente facile capire qual’è il tuo problema. Se c’è qualcosa che non va sii più esplicito.

  10. w0rm / Lug 25 2009 4:09 pm

    Con ubuntu basta un
    sudo apt-get install codeblocks
    😉

Trackbacks

  1. bixbi » Blog Archive » CC++ IDE WINLinux

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

%d blogger hanno fatto clic su Mi Piace per questo: